Перейти к содержимому

Как получить размер файла 1с

  • автор:

1с8.2 Как узнать размер файла

Файл.Размер (File.Size)
Файл (File)
Размер (Size)
Синтаксис:
Размер()
Возвращаемое значение:
Тип: Число.
Описание:
Определяет размер файла (в байтах).

Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Примечание:
Применим только к файлам, которые реально существуют.
Для работы метода на веб-клиенте, необходимо предварительно подключить расширение работы с файлами.

Как получить размер файла 1с

Объект языка 1С «Файл» позволяет:

  • файл 1С — получить путь к файлу (каталог без имени файла), имя без расширения, только расширение
  • файл 1С — проверить наличие файла
  • файл 1С — определить файл это или каталог
  • файл 1С — получить размер файла
  • файл 1С — работать с атрибутами файла (время измененеия, только чтение, скрытые файлы).

Пример файл 1С — проверка наличия каталога на диске:
Функция ПолучитьКаталогПоИмениФайла(ИмяФайла)

//обращаемся к файлу, на этот момент существование файла не проверяется
Файл = Новый Файл(ИмяФайла);

//напрямую проверяем существование
Если не Файл.Существует() Тогда
Сообщить(«Ошибка. Файл с именем ‘» + ИмяФайла + «‘ не существует»);
Возврат ИмяФайла;
КонецЕсли;

//проверка на каталог
Если Файл.ЭтоКаталог() Тогда
//если последняя буква не «\», то добавляем ее
Возврат ?(Прав(СокрП(ИмяФайла), 1) = «\», ИмяФайла, СокрП(ИмяФайла) + «\»);
КонецЕсли;

//возвращаем путь (т.е. только каталог из имени файла)
Возврат Файл.Путь;

Пример файл 1С — проверка существования файла на диске:
Функция ФайлМожноЗаписывать(ИмяФайла)

//обращаемся к файлу, на этот момент существование файла не проверяется
Файл = Новый Файл(ИмяФайла);

//напрямую проверяем существование
Если не Файл.Существует() Тогда
Сообщить(«Ошибка. Файл с именем ‘» + ИмяФайла + «‘ не существует»);
Возврат ИмяФайла;
КонецЕсли;

//вернет ИСТИНА, если нельзя записывать (т.е. только чтение «установлен»)
Если Файл.ПолучитьТолькоЧтение() Тогда
Попытка
Файл.УстановитьТолькоЧтение(Ложь);
Исключение
//здесь мы окажемся, если у пользователя, под которым работает клиент 1С нет прав снять этот реквизит
Возврат Ложь;
КонецПопытки;
КонецЕсли;

Пример файл 1С — получение размера файла в байтах, килобайтах, мегабайтах:

Функции для работы с файлами и директориями

В 1С Предприятии для работы с файловой системой предусмотрены специальные объекты и методы. Они позволяют создавать файлы и директории, а также получать размер, полный путь, расширение и другую информацию. Популярностью пользуются следующие глобальные методы: НайтиФайлы, КопироватьФайл, ПереместитьФайл, ПолучитьИмяВременногоФайла, КаталогВременныхФайлов, СоздатьКаталог, УдалитьФайлы. Также для работы с файловой системой используются объекты: Файл, ТекстовыйДокумент, ЗаписьТекста, ЧтениеТекста.

Объект Файл

Объект предоставляет доступ к параметрам файлов и каталогов. С помощью методов и свойств данного объекта можно получить различную информацию о файле или каталоге.

Глобальные методы

Ищет файлы и каталоги по заданному пути. Вторым параметром можно указать фильтр по расширениям файлов.

Данная функция позволяет скопировать файл в любое указанное место.

Вырезать и вставить файл в новое место.

Возвращает уникальное имя временного файла. Файл не создается. Если создать файл с данным именем, то при следующем запуске платформы он будет удален автоматически.

Возвращает имя каталога временных файлов пользователя, под которым запущено приложение.

Создает новый каталог по указанному файловому пути.

Удаление файлов и директорий по указанным путям.

Объект ТекстовыйДокумент

Объекты ЗаписьТекста и ЧтениеТекста

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

Как получить размер файла 1с

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

  • Как записать произвольное значение в файл
  • Как восстановить произвольное значение из файла
  • Как записать текстовый файл
  • Как прочитать текстовый файл
  • Как проверить существование файла
  • Как скопировать файл
  • Как переместить файл
  • Как найти файлы в каталоге
  • Как удалить файл
  • Как удалить файлы в каталоге по маске
  • Как получить имя временного файла
  • Как прочитать атрибуты файла
  • Как установить атрибуты файла
  • Как узнать размер файла
  • Как вытащить расширение файла из его пути
  • Как вытащить имя файла без расширения
  • Как создать каталог
  • Как проверить существование каталога
  • Как удалить каталог вместе с содержимым
  • Как получить каталог временных файлов
  • Как сохранить произвольное значение во временное хранилище
  • Как прочитать произвольное значение из временного хранилища
  • Как перезаписать уже сохраненное значение во временном хранилище
  • Сколько времени хранится значение, сохраненное во временном хранилище
  • Как сохранить значение во временное хранилище на всё время жизни формы
  • Как сохранить значение во временное хранилище на всё время сеанса пользователя
  • Как удалить значение из временного хранилища
  • Как узнать является ли строка адресом во временном хранилище
  • Как передать файл с клиента на сервер
  • Как прочитать файл на сервере из временного хранилища
  • Как передать файл с сервера на клиент
  • Скачать и выполнить эти примеры на компьютере

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

С уважением, Владимир Милькин (преподаватель школы 1С программистов и разработчик обновлятора).

Владимир Милькин

Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *