Перейти к содержимому

Как создать папку в 1с

  • автор:

Как создать папку в 1с

Следующие функции языка 1С позволяют манипулировать файлами:

  • СоздатьКаталог 1С
  • НайтиФайлы 1С
  • КопироватьФайл 1С
  • ПереместитьФайл 1С
  • УдалитьФайлы 1С
  • РазделитьФайл 1С
  • ОбъединитьФайлы 1С.

Работа с каталогами — СоздатьКаталог 1С

//создает недостающие каталоги в указанном пути
//если каталога нет – создаст всю вложенную структуру
//если есть D:\Temp, то создаст подкаталоги
СоздатьКаталог(«D:\Temp\1\2\3»)

Поиск файлов — НайтиФайлы 1С

//найти все файлы 1С в каталоге «Sc»
НайденныеФайлы = НайтиФайлы(«D:\Sc», «*»);

//найти все ТЕКСТОВЫЕ файлы 1С в каталоге, включая вложенные подкаталоги
НайденныеФайлы = НайтиФайлы(«D:\Sc», «*.txt», Истина);

//найти все файлы 1С в каталоге, в имени которых встречается слово «копия»
НайденныеФайлы = НайтиФайлы(«D:\Sc», «*копия*»);

//найти все файлы 1С в каталоге, в имени которых встречается любая цифра в скобочках, например «(1)» или «(100)»
НайденныеФайлы = НайтиФайлы(«D:\Sc», «*(*)*»);

//найти все файлы 1С в каталоге, в имени которых встречается цифра в скобочках меньше 10, например «(1)» или «(9)»
НайденныеФайлы = НайтиФайлы(«D:\Sc», «*(?)*»);

Для каждого Файл из НайденныеФайлы Цикл
Если Файл.ЭтоКаталог() Тогда
Продолжить;
КонецЕсли;

Копирование, перемещение и удаление файлов — КопироватьФайл 1С, ПереместитьФайл 1С, УдалитьФайлы 1С

ИмяФайла = «Текстовый файл.txt»;
КаталогИсточник = «D:\sc\»;
КаталогПриемник = «D:\»;

//копирование файла
ФайлИсточник = Новый Файл(КаталогИсточник + ИмяФайла);
Если не ФайлИсточник.Существует() или ФайлИсточник.ЭтоКаталог() Тогда
ВызватьИсключение «Файл ‘» + КаталогИсточник + ИмяФайла + «‘ не существует или является каталогом»;
КонецЕсли;

Попытка
КопироватьФайл(КаталогИсточник + ИмяФайла, КаталогПриемник + ИмяФайла);
Исключение
ВызватьИсключение «Нет прав на копирование файла»;
КонецПопытки;

ФайлПриемник = Новый Файл(КаталогПриемник + ИмяФайла);
Если не ФайлПриемник.Существует() или ФайлПриемник.Размер() <> ФайлИсточник.Размер() Тогда
ВызватьИсключение «Не удалось корректно скопировать файл»;
КонецЕсли;

//перемещение файла
Попытка
ПереместитьФайл(КаталогИсточник + ИмяФайла, КаталогПриемник + ИмяФайла);
Исключение
ВызватьИсключение «Нет прав на копирование файла»;
КонецПопытки;

ФайлПриемник = Новый Файл(КаталогПриемник + ИмяФайла);
Если не ФайлПриемник.Существует() Тогда
ВызватьИсключение «Не удалось корректно перенести файл»;
КонецЕсли;

Разделение и слияние файлов — РазделитьФайл 1С, ОбъединитьФайлы 1С

//функция создает каталог с именем файла
//в нем создает разделенные части файла, каждая размером в указанное кол-во мегабайт
//каждую часть сжимает архиватором
//возвращает имя каталога

Как создать папку средствами 1С?

Тип: Строка. Полное имя создаваемого каталога.
Допускается использование схемы ftp для адресации файлов. При использовании этой схемы в адресах необходимо указывать прямые слеши ‘/’, а не обратные ‘\’.
Описание:

Создает новый каталог файлов.

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Примечание:

Существование каталога <ИмяКаталога> не приводит к ошибке.
Для работы метода на веб-клиенте, необходимо предварительно подключить расширение работы с файлами.
Пример:

там прям функция написана (в СП):

Функция ПроверитьСуществованиеКаталога(ИмяКаталога) Экспорт
КаталогНаДиске = Новый Файл(ИмяКаталога);
Если КаталогНаДиске.Существует() Тогда
Возврат Истина;
Иначе
Ответ = Вопрос(«Каталог не существует. Создать?»,
РежимДиалогаВопрос.ОКОтмена);
Если Ответ = КодВозвратаДиалога.ОК Тогда
СоздатьКаталог(ИмяКаталога);
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;
КонецЕсли;
КонецФункции

Как создать папку в 1с

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

  • Как записать произвольное значение в файл
  • Как восстановить произвольное значение из файла
  • Как записать текстовый файл
  • Как прочитать текстовый файл
  • Как проверить существование файла
  • Как скопировать файл
  • Как переместить файл
  • Как найти файлы в каталоге
  • Как удалить файл
  • Как удалить файлы в каталоге по маске
  • Как получить имя временного файла
  • Как прочитать атрибуты файла
  • Как установить атрибуты файла
  • Как узнать размер файла
  • Как вытащить расширение файла из его пути
  • Как вытащить имя файла без расширения
  • Как создать каталог
  • Как проверить существование каталога
  • Как удалить каталог вместе с содержимым
  • Как получить каталог временных файлов
  • Как сохранить произвольное значение во временное хранилище
  • Как прочитать произвольное значение из временного хранилища
  • Как перезаписать уже сохраненное значение во временном хранилище
  • Сколько времени хранится значение, сохраненное во временном хранилище
  • Как сохранить значение во временное хранилище на всё время жизни формы
  • Как сохранить значение во временное хранилище на всё время сеанса пользователя
  • Как удалить значение из временного хранилища
  • Как узнать является ли строка адресом во временном хранилище
  • Как передать файл с клиента на сервер
  • Как прочитать файл на сервере из временного хранилища
  • Как передать файл с сервера на клиент
  • Скачать и выполнить эти примеры на компьютере

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

С уважением, Владимир Милькин (преподаватель школы 1С программистов и разработчик обновлятора).

Владимир Милькин

Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Создание папок номенклатуры в 1С

В данной статье мы рассмотрим, как создавать и работать с папками в справочнике «Номенклатура». Данный функционал актуален для любой современной конфигурации 1С, потому пример будет приведен на конфигурации 1С 8.3 Управление торговлей 11.4.2.

1. Что такое папка Номенклатуры?

Под созданием «Папки» в Номенклатуре, подразумевается создание «Группы видов номенклатуры», категории, позволяющей сгруппировать не саму номенклатуру, а ее вид. сам вид, объединяет конкретную номенклатуру по общим признакам в 1С Управление торговлей редакция 11.

Группа видов номенклатуры, так же называемая «Папка номенклатуры» в справочнике номенклатуры.

2. Как создать Группу видов номенклатуры?

Теперь, когда мы определились, что такое «папка», можно приступать к ее созданию.

Для этого, необходимо в справочнике «Номенклатура», доступном в 1С Предприятие Управление торговлей 11 по пути: НСИ и Администрирование – НСИ — Номенклатура

Путь к справочнику «Номенклатура» в 1С

В части справочника, отображающей виды номенклатуры, нажать правой кнопкой мыши на список.

Вид справочника «Номенклатура» в 1С. Цифрой 1 на скриншоте обозначена честь со списком номенклатуры, под цифрой 2, часть, отображающая виды номенклатуры.

После нажатия, появится список опций, необходимо выбрать строку «Группу видов номенклатуры» или воспользоваться комбинацией клавиш Ctrl + F9.

Окно выбора создания группы видов номенклатуры

После этого в 1С 8 Управление торговлей 11, появится форма, в которой нужно ввести название группы, ее иерархию

Форма создания группы

3. Настройка группы видов номенклатуры

В форме создания группы, необходимо ввести название группы, для примера, назовем ее «Папка номенклатуры».

После ввода названия, мы можем выбрать иерархию группы.
Новая группа номенклатуры в 1С, может быть внутри любой из уже созданных групп, или если отчистить поле «Группа видов номенклатуры», новая группа, будет создана независимой, от уже существующих групп.

Иерархия групп, выбирается через поле «Группа видов номенклатуры», новая группа может быть подчинена существующим группам.

К любой группе, пользователь может добавить свое примечание (комментарий), заметки можно настроить в 1С Управление торговлей, версия 11.

При отмеченной галочке «показывать заметки других пользователей», пользователь, открывший заметки, будет видеть комментарии всех пользователей к данной группе.

Отмеченная галочка «Показывать удаленные», будет показывать удаленные комментарии с соответствующей пометкой.

Так же, можно добавить «Файлы» и «Задаче» к определенной группе.
Данные механизмы, работают, если они доступны, одинаково для всех элементов системы 1С 8 Управление торговлей 11.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *