Перейти к содержимому

Как получить пользователя иб в 1с

  • автор:

Как получить пользователя иб в 1с

Глобальный контекст (Global context)
ПользователиИнформационнойБазы (InfoBaseUsers)
Использование:

Только чтение.
Описание:

Тип: МенеджерПользователейИнформационнойБазы. Используется для управления списком пользователей информационной базы.

Сервер, толстый клиент, внешнее соединение.

МенеджерПользователейИнформационнойБазы.ТекущийПользователь (InfoBaseUsersManager.CurrentUser)
МенеджерПользователейИнформационнойБазы (InfoBaseUsersManager)
ТекущийПользователь (CurrentUser)
Синтаксис:

ТекущийПользователь()
Возвращаемое значение:

Тип: ПользовательИнформационнойБазы. Если текущий пользователь не задан, то в качестве текущего пользователя будет возвращен пользователь с пустым именем и идентификатором объекта, полученного методом НайтиПоИмени, если в параметре указано пустое имя.
Описание:

1С 8.3 Получить список действующих пользователей — Программист 1С Минск. Автоматизация бизнеса.

// Добавлена проверка на статус ВходВПрограмму
// из ХранилищеЗначенийОбъекта (Хранилище Значений Объекта)
// Производим чтение структуры и проверяем на условие истина(булево)
СписокВыбрПольз = Параметры . ПользователиСБыстрымДоступом ;
Запрос = Новый Запрос ( «ВЫБРАТЬ
|Ссылка ИЗ Справочник.Пользователи
| ГДЕ НЕ ПометкаУдаления
| И НЕ Недействителен
| И НЕ Служебный» );

Выборка = Запрос . Выполнить (). Выбрать ();
Пока Выборка . Следующий () Цикл
Если СписокВыбрПольз . НайтиПоЗначению ( Выборка . Ссылка ) = Неопределено Тогда
ПользовательОбъект = Выборка . Ссылка . Получитьобъект ();
ХранилищеЗн = ПользовательОбъект . СвойстваПользователяИБ ;
ХранилищеЗнПолучить = ХранилищеЗн . Получить ();
Если НЕ ХранилищеЗнПолучить = Неопределено
И ХранилищеЗнПолучить . ВходВПрограммуРазрешен Тогда
ВсеЮзеры . Добавить (). Пользователь = Выборка . Ссылка ;
КонецЕсли;
Иначе
ПользовательОбъект = Выборка . Ссылка . Получитьобъект ();
ХранилищеЗн = ПользовательОбъект . СвойстваПользователяИБ ;
ХранилищеЗнПолучить = ХранилищеЗн . Получить ();
Если НЕ ХранилищеЗнПолучить = Неопределено
И ХранилищеЗнПолучить . ВходВПрограммуРазрешен Тогда
СписокЮзеров . Добавить (). Пользователь = Выборка . Ссылка ;
КонецЕсли;
КонецЕсли;
КонецЦикла;

ВсеЮзеры . Сортировать ( «Пользователь Возр» );
СписокЮзеров . Сортировать ( «Пользователь Возр» );

1С 8.3. Как правильно узнать текущего пользователя информационной базы на сервере?

Код рабочий, но как правильнее сделать? Серверный вариант.

если типовая конфигурация:

Если у справочника пользователи есть реквизит ИдПользователяБазы :

Дизайн сайта / логотип © 2023 Stack Exchange Inc; пользовательские материалы лицензированы в соответствии с CC BY-SA . rev 2023.6.20.43502

Нажимая «Принять все файлы cookie» вы соглашаетесь, что Stack Exchange может хранить файлы cookie на вашем устройстве и раскрывать информацию в соответствии с нашей Политикой в отношении файлов cookie.

Как получить пользователя ИБ в 1С

Ребят, как можно получить пользователя информационной базы 1С? Это же не справочник в конфигурации. У меня есть только Пользователь, подскажите как решить такую проблему!

У элемента справочника Пользователи есть идентификатор пользователя ИБ, по нему и можно получить пользователя информационной базы.

Пример для текущего пользователя:

  • Создание внешней печатной формы для управляемого приложения в 1С 8.3
  • Получение уникального идентификатора из ссылки 1С
  • Параметры и ключи запуска в 1С 8.3 и 8.2
  • Настройка двухстороннего обмена данными между конфигурациями «Управление торговлей 10.3» и «Бухгалтерия предприятия 2.0» в 1С 8

Подпишитесь на наш YouTube канал

Связаться с нами можно по телефону:

Наша команда предоставляет услуги по консультированию, настройке и внедрению 1С.

Услуги и цены можно увидеть по ссылке.

Будем рады помочь Вам!

Свежие записи

  • Как выгрузить базу из 1С 8.3 на флешку
  • Поиск и удаление дублей в 1С 8.3
  • Настройка 1С ЗУП 8.3 — пошаговая инструкция
  • Зарплатный проект в 1С 8.3 Бухгалтерия
  • Оказание услуг в 1С 8.3 — пошаговая инструкция
  • Как сделать договор в 1С 8.3: шаблоны договоров

Подписывайтесь на наш YouTube канал, чтобы узнать больше о 1С. Там вы найдете множество видео-уроков. Ждем вас!

При использовании данного сайта, вы подтверждаете свое согласие на использование файлов cookie в соответствии с настоящим уведомлением в отношении данного типа файлов. Если вы не согласны с тем, чтобы мы использовали данный тип файлов, то вы должны соответствующим образом установить настройки вашего браузера или не использовать сайт

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *