Перейти к содержимому

Как сделать гиперссылку в 1с

  • автор:

Как сделать гиперссылку в карточке товара.

(5) Обалдеть.. я 1С-ник с >15 летним стажем
Я не понимаю что значит "Включил редактирование"
Я не понимаю в какие такие "свойства ячеек" можно зайти в карточке справочника
Я не понимаю где там "галка сохранить" и что это вообще за "галка" такая.

Наверное всё дело в ошибочном применении терминологии.

(9) Что это за "таблица", откуда она взялась?
Мы вообще говорим о конфигураторе?

В (0) шла речь о "карточке товара". Карточкой обычно называют форму элемента справочника. На форму можно поместить декорацию-надпись с флагом "гиперссылка" и задать ей обработчик выполняющий некую команду, в т.ч. запуск внешнего приложения или команду системы.

(11) А если я посоветую "забыть всё, что знаешь", "представить себя первоклассником" и задать вопрос с этой позиции? Интересно, поможет?

Какую задачу ты пытаешься решить?

(15) Ты хочешь создать самому себе одну(!) кнопку для конкретного товара и нажимать на неё, чтобы переходить по некоей ссылке?
Ведь явно нет.

Давай для начала определимся, в каком именно месте должны быть эта кнопка? Ведь у тебя явно формируется некий список товаров.. Как ты его формируешь?

На втором фото должна быть гиперссылка на ресурс в интернете.

То, что вы просите, даже специалист не сделает за 5-10 минут.
Штатными функциями это не предусмотрено.

Придётся менять конфигурацию, снимать её с поддержки, что приведёт к невозможности автоматического обновления.
Придётся либо через доп.реквизиты либо через поле таблицы справочника организовать место где будет храниться ссылка на "интернет-магазин" в базе данных, организовать выборку и вывод этой ссылки в "карточку" в виде "гиперссылки", для которой будет предусмотрен обработчик запускающий внешний или внутренний браузер по ссылке.
Никто не будет выкладывать "инструкцию для чайников" как это сделать.

(30) Ну как пример использования ссылок в 1С подскажу.

— слева в меню пункт "CRM и маркетинг"
— пункт "Настройки и справочники"
— пункт "Виды контактной информации"
— встаньте на строку "Контактная информация справочника "Партнеры""
-нажмите кнопку "Создать", откроется форма заведения вида контактной информации
— в поле Тип выберите "Веб страница",
— в поле Наименование наберите "Корпоративный сайт",
— нажмите "Записать и закрыть"

Теперь у вас для справочника "Партнеры" (Клиенты/Поставщики) на вкладке "Адреса и телефоны" будет доступно поле для указания ссылки на сайт. И даже кнопочка есть, которая открывает этот сайт в браузере.

Жаль, что для номенклатур разработчики не предусмотрели такой функционал.

Надпись на форме с интерактивными ссылками (1С)

Чтобы отобразить на форме надпись с кликабельными ссылками (например, на объекты базы), можно воспользоваться типом ФорматированнаяСтрока .

1) создаем реквизит формы с именем, н-р, Сообщение и типом ФорматированнаяСтрока

2) выносим его на форму, получая “Поле надписи”

Устанавливать параметр Гиперссылка не нужно.

При этом у поля есть события:

  • Нажатие
  • ОбработкаНавигационнойСсылки

Для простого открытия ссылок на объекты базы обрабатывать эти события не придется.

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рассмотрим варианты размещения элементов на форме на примере вывода реквизитов документа на форму документа, состав документа представлен на рис. 1:

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 1. Реквизиты документа

Добавляем форму документа, по умолчанию все элементы формы будут располагаться сверху вниз по порядку (рис. 2):

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 2. Расположение элементов на форме по умолчанию

Сделаем форму более удобной для просмотра и ввода значений.

Поля Документ основание, Ответственный и Комментарий сдвинем вниз, для этого выделяем эти поля и нажимаем стрелку вниз (рис. 3):

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 3. Перемещение полей

Поле Документ основание представим в виде ссылки, чтобы при нажатии открывалось значение реквизита Документ основание. Открываем свойства поля ДокументОснование правой кнопкой мыши Свойства или Alt Enter (рис. 4):

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 4. Открытие свойств поля

В окне Свойства у свойства Вид устанавливаем значение Поле надписи, отмечаем галочкой свойство Гиперссылка (рис. 5). Можно убрать заголовок поля Документ основание:, если у свойства ПоложениеЗаголовка изменить значение на Нет.

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 5. Настройка свойств поля-гиперссылки

Зададим обработку события нажатия гиперссылки: в окне Свойства в разделе События нажимаем на значок лупы у события Нажатие (рис. 6):

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 6. Событие Нажатие

В открывшемся окне оставляем значение Создать на клиенте, нажимаем ОК. Откроется модуль формы документа с шаблоном процедуры ДокументОснованиеНажатие(), добавляем строку ПоказатьЗначение(,Объект.ДокументОснование); (рис. 7):

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 7. Обработка нажатия на гиперссылку

Само значение реквизита ДокументОснование будет определяться при создании на основании, задаем это на вкладке Ввод на основании (рис. 9):

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 9. Ввод на основании

и прописываем в процедуре ОбработкаЗаполнения() в модуле объекта документа (рис. 10, рис. 11):

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

УФ: Размещение элементов на форме 1 Гиперссылка в 1С

Рис. 10. Открытие модуля объекта документа Рис. 11. Создание процедуры ОбработкаЗаполнения() в модуле объекта документа

В процедуру ОбработкаЗаполнения() в модуле объекта документа добавим строку ДокументОснование = ДанныеЗаполнения.Ссылка;.

Теперь в пользовательском режиме у созданного на основании документа поле Документ основание будет выглядеть так (рис. 12):

Гиперссылка в ячейке табличной части 1с 8

ГиперСсылка (HyperLink)
Использование:
Чтение и запись.
Описание:
Тип: Булево. Позволяет отображать значения ячеек данной колонки как гиперссылки. При выборе любой ячейки данной колонки будет порождаться событие Выбор.

Процедура ПредложенияВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
Если НЕ ВыбраннаяСтрока=Неопределено Тогда
Если Колонка.Имя=»ЦенаЗакупки» Тогда
Ц=»»;
СтандартнаяОбработка=Ложь;
ПараметрыОтбораПредложений = Новый Структура;
ПараметрыОтбораПредложений.Вставить(«КлючСтроки», ВыбраннаяСтрока.КлючСтроки);
ПараметрыОтбораПредложений.Вставить(«СкладПоставки», ВыбраннаяСтрока.СкладПоставки);
ПараметрыОтбораПредложений.Вставить(«Артикул», ВыбраннаяСтрока.Артикул);

СтрокиПоАртикулу = ПредложенияПоставщиков.Выгрузить(ПараметрыОтбораПредложений,»ЦенаЗакупки,МинЗаказ,Валюта»);
СтрокиПоАртикулу.Сортировать(«МинЗаказ Возр»);

Для Каждого стр из СтрокиПоАртикулу Цикл

КонецЦикла;
Список=Новый СписокЗначений;
Список.Добавить(КодВозвратаДиалога.ОК,»Всё ясно»);
Ответ=Вопрос(Ц,Список. »Мин.заказ и цены»);
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *