Перейти к содержимому

Как получить имя сервера 1с

  • автор:

Какой функцией можно получить имя информационной базы сервера 1С

Описание информационной базы (IInfoBaseShort)
Name (Name)
Использование:

Только чтение.
Описание:

Тип: Строка.
Содержит ссылочное имя информационной базы. Совпадает со значением свойства Name. Должно быть уникальным среди всех информационных баз, зарегистрированных в данном реестре. При сравнении регистр букв не имеет значения.

Дарю, я сегодня щедрый

Глобальный контекст.СтрокаСоединенияИнформационнойБазы (Global context.InfoBaseConnectionString)
Глобальный контекст (Global context)
СтрокаСоединенияИнформационнойБазы (InfoBaseConnectionString)
Синтаксис:

СтрокаСоединенияИнформационнойБазы()
Возвращаемое значение:

Возвращает Строка соединения информационной базы, которую, например, можно использовать для запуска 1С:Предприятия средствами встроенного языка в Automation, Менеджер COM-соединений. Пример результата метода: File="C:\1cv8\Base".

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

В типовых (БП 2.0, например) в общем модуле СоединенияИБКлиентСервер:

// Возвращает полный путь к информационной базе (строку соединения).
//
// Параметры
// ПризнакФайловогоРежима — Булево — выходной параметр. Принимает значение
// Истина, если текущая ИБ — файловая;
// Ложь — если клиент-серверная.
// ПортКластераСерверов — Число — входной параметр. Задается в случае, если
// кластер серверов использует нестандартный номер порта.
// Значение по умолчанию — 0, означает, что
// кластер серверов занимает номер порта по умолчанию.
//
// Возвращаемое значение:
// Строка — строка соединения ИБ.
//
Функция ПутьКИнформационнойБазе(ПризнакФайловогоРежима = Неопределено, Знач ПортКластераСерверов = 0) Экспорт
СтрокаСоединения = ПолучитьСтрокуСоединенияИнформационнойБазы(ПортКластераСерверов);
ПозицияПоиска = Найти(Врег(СтрокаСоединения), "FILE=");
Если ПозицияПоиска = 1 Тогда // файловая ИБ
ПутьКИБ = Сред(СтрокаСоединения, 6, СтрДлина(СтрокаСоединения) — 6);
ПризнакФайловогоРежима = Истина;
Иначе
ПризнакФайловогоРежима = Ложь;
ПозицияПоиска = Найти(Врег(СтрокаСоединения), "SRVR=");
Если НЕ (ПозицияПоиска = 1) Тогда
Возврат Неопределено;
КонецЕсли;
ПозицияТочкиСЗапятой = Найти(СтрокаСоединения, ";");
НачальнаяПозицияКопирования = 6 + 1;
КонечнаяПозицияКопирования = ПозицияТочкиСЗапятой — 2;
ИмяСервера = Сред(СтрокаСоединения, НачальнаяПозицияКопирования, КонечнаяПозицияКопирования — НачальнаяПозицияКопирования + 1);
СтрокаСоединения = Сред(СтрокаСоединения, ПозицияТочкиСЗапятой + 1);
// позиция имени сервера
ПозицияПоиска = Найти(Врег(СтрокаСоединения), "REF=");
Если НЕ (ПозицияПоиска = 1) Тогда
Возврат Неопределено;
КонецЕсли;
НачальнаяПозицияКопирования = 6;
ПозицияТочкиСЗапятой = Найти(СтрокаСоединения, ";");
КонечнаяПозицияКопирования = ПозицияТочкиСЗапятой — 2;
ИмяИБНаСервере = Сред(СтрокаСоединения, НачальнаяПозицияКопирования, КонечнаяПозицияКопирования — НачальнаяПозицияКопирования + 1);
ПутьКИБ = """" + ИмяСервера + "\" + ИмяИБНаСервере + """";
КонецЕсли;
Возврат ПутьКИБ;
КонецФункции

Имя сервера 1С

В конфигурации системы 1С Предприятие клиент-серверном варианте для хранения информации используется SQL-сервер. Но, при этом, к серверу SQL обращаться будет лишь сам Сервер 1С:Предприятия. Клиентская база конфигурации системы 1С Предприятия не может прямо обращаться к SQL-серверу. Подробно об установке и настройках SQL-сервера для 1С можно узнать из документов по Microsoft SQL Server. Однако, чтобы Сервер 1С:Предприятие с сервером SQL работал корректно необходимо соблюдать следующие настройки:

● Чтобы получить доступ к SQL-серверу от «1С: Предприятие» нужно установить компоненты Microsoft Data Access версии 2.6 или новее;

● Настройки прав доступа к базе данных SQL-сервера устанавливаются тем пользователем, имя которого фигурирует в обращениях к базам данных. Для начала, нужно подключить утилиту SQL Server Enterprise Manager на компьютере, на котором установлен сам сервер, после чего, переходим по пути «Console Root»-«Microsoft SQL Servers»-«SQL Server Group»-«Local» и запускаем панель свойств. SQL-сервер может подтвердить два возможных способа аутентификации информации: SQL Server and Windows и Windows only. Второй способ аутентификации разрешает обращение к серверу SQL от Сервера 1С: Предприятие от самого имени пользователя, что может уравнять права доступа, что не всегда удобно и соответствует соображениям безопасности. Поэтому, лучше выбрать первый вариант, так как в этом варианте обращение к базе данных будет происходить от имени того пользователя, который был указан в виде юзера SQL-сервера во время создания базы данных. Стоит отметить, что данный пользователь должен иметь доступ и к базе данных, и возможность создания информационных баз на SQL-сервере, и на прочтение таблиц из информационной базы Master;

● Для случая, когда серверы SQL и «1С:Предприятие» располагаются не на одном и том же компьютере, то нужно настроить сетевые протоколы доступа к серверу SQL. Это делается с помощью утилиты SQL Server Client Network Utillity. Во вкладке General нужно избрать перечень с сетевыми протоколами, по которым получают доступ к серверу SQL, через его имя. Самым эффективным способом является использование протокола ТСР/IP.

2. Получение имени сервера 1С

Далее будет представлено программное решение для случая, когда нужно получить имя сервера 1С и информационной базы во время запуска формы для внешней обработки.

В этом случае, имя вернётся в строчном формате.

Результат выполнения данной операции будет следующий: Srvr=«<имя компьютера сервера>», Ref= «<имя базы на сервере>».

3. Ошибка «После переименования сервера не запускается кластер серверов 1С Предприятие»

Иногда, у пользователей, при установке сервера 1С Предприятие и СУБД возникает потребность переименования сервера (компьютера, на котором находится сервер). Когда переименование произошло, то система 1С больше не стала видеть кластер серверов 1С Предприятие. А во время произведения подключения к кластеру появляется окно с сообщением с текстом о том, что кластер не был найден.

Чтобы этого не было, после того, как сервер был переименован, необходимо запустить файл: C:\Program Files (x86)\1cv8\srvinfo\1cv8wsrv.lst. После чего, нужно в этом файле поменять пошлое имя на новое, к примеру с

Также необходимо поступить с такими файлами: 1CV8Clst и 1CV8Clsto, которые располагаются по следующей ссылке: C:\Program Files (x86)\1cv8\srvinfo\reg_1541. Далее, там необходимо поменять те строки, где встречается прошлое название на новое.

Ещё одно действие, которое нужно сделать, во избежание данной ошибки, — это зайти в свойства центрального кластера внутри оснастки «Администрирование серверов 1С Предприятия» и аналогично заменить название, как демонстрируется ниже:

Cвойства центрального кластера

После того как сделать перезагрузку службы «1С: Enterprice 8.3 Server Agent», ошибка появляться не будет.

Этот хост неизвестен 1С: как исправить

Наиболее часто эта ошибка возникает при подключении к серверу через интернет. В этом случае в кластере серверов указывается вместо локального имени сервера IP-адрес, по которому подключение перенаправляется на локальный хост сервера.

Такое подключение и приводит к ошибке «неизвестного сервера», несмотря на то, что в форме настройки явно указан его IP-адрес:

  • Ошибка server_addr=Server-1C descr=11001 (0x00002AF9): Этот хост неизвестен. line=1050 file=src\DataExchangeCommon.cpp.

Что же происходит при подключении?

Введенный IP-адрес указывает на кластер серверов, который в ответ на запрос клиента сообщает зарегистрированное в кластере локальное имя сервера Server-1C. Но подключиться к нему по удаленной сети через интернет не удается, поскольку это имя не имеет в сети корректного dns-разрешение имени:

  • 168.101.37 — Server-1С.

Исправление ошибки

Для исправления ошибки необходимо в файл hosts добавить строчку c нужной информацией:

  • [IP] [Имя сервера]:
    • [IP] — IP-адрес, указанный в настройках подключения к информационной базе
    • [Имя сервера] — название хоста, которое идет после параметра «server_addr=».

    Файл hosts находится в каталоге C:\Windows\System32\drivers\etc.

    На редактирование файла hosts нужны административные права.

    Откройте файл hosts встроенным в операционную систему Windows редактором Блокнот.

    Добавьте в содержимое строчку описанного ниже вида.

    Расшифровка 192.168.101.37 Server-1C:

    • 168.101.37 — IP-адрес подключения информационной базы;
    • Server-1C — имя сервера.
    • Ошибка при выполнении операции с информационной базой 1С 8.3
    • 1С удаление: указанная учетная запись уже существует
    • Установка запрещена на основании системной политики 1С 8.3
    • Обнаружено неправомерное использование данного программного продукта в 1С: как убрать
    • Ошибка ввода пинкода. Пинкод не укомплектован в 1С 8.3

    Подписывайтесь на наши YouTube и Telegram чтобы не пропустить
    важные изменения 1С и законодательства

    Помогла статья?

    Получите еще секретный бонус и полный доступ к справочной системе БухЭксперт8 на 14 дней бесплатно

    Похожие публикации

      ФНС подсказала, как быть, если для заполнения расчета по страховым.Работнику, выезжающему в командировку (или вернувшемуся из нее) в выходной.К экспертам сервиса Роструда «Онлайн-инспекция.рф» работодатель обратился с вопросом: нужно.С будущего года можно будет воспользоваться еще одним соцвычетом по.

    (29 оценок, среднее: 4,24 из 5)

    1C:Enterprise

    Строка соединения— строка, задающая параметры информационной базы, каждый из которых представляет собой фрагмент вида <Имя параметра>=<Значение>, где:

    Имя параметра — имя параметра;
    Значение — его значение.

    Фрагменты отделяются друг от друга символами ‘;’.
    Если значение содержит пробельные символы, то оно должно быть заключено в двойные кавычки («).
    Набор параметров определяется вариантом создаваемой информационной — базы — файловый или клиент-серверный.

    Для файлового варианта определен параметр:

    File — имя каталога, в котором размещается файл информационной базы;
    Locale — язык (страна), который будет использован при открытии или создании информационной базы. Допустимые значения такие же как у параметра <Форматная строка> метода Формат. Параметр Locale задавать не обязательно. Если не задан, то будут использованы региональные установки текущей информационной базы.

    Для клиент-серверного варианта определены параметры:

    Ref — имя информационной базы на сервере «1С:Предприятия»;
    DBMS — тип используемого сервера баз данных:

    MSSQLServer — Microsoft SQL Server;
    PostgreSQL — PostgreSQL;
    IBMDB2 — IBM DB2;
    OracleDatabase — Oracle Database.

    DBSrvr — имя сервера баз данных;
    DB — имя базы данных в сервере баз данных;
    DBUID — имя пользователя сервера баз данных;
    DBPwd — пароль пользователя сервера баз данных. Если пароль для пользователя сервера баз данных не задан, то данный параметр можно не указывать;
    SQLYOffs — смещение дат, используемое для хранения дат в Microsoft SQL Server. Может принимать значения 0 или 2000. Данный параметр задавать не обязательно. Если не задан, принимается значение 0;
    Locale — язык (страна), (аналогично файловому варианту);
    CrSQLDB — создать базу данных в случае ее отсутствия («Y»|»N». «Y» — создавать базу данных в случае отсутствия, «N» — не создавать. Значение по умолчанию — N).
    SchJobDn — в созданной информационной базе запретить выполнение регламентных созданий (Y/N). Значение по умолчанию — N;
    SUsr — имя администратора кластера, в котором должен быть создан начальный образ. Параметр необходимо задавать, если в кластере определены администраторы и для них аутентификация операционной системы не установлена или не подходит;
    SPwd — пароль администратора кластера.

    Для всех вариантов определены параметры:

    Usr — имя пользователя;
    Pwd — пароль;
    LicDstr — разрешить получение клиентских лицензий через сервер «1С:Предприятия» («Y«|»N«).

    «Y» — получать клиентскую лицензию через сервер «1С:Предприятия». Если клиентское приложение не получило программную лицензию или аппаратную лицензию из локального ключа HASP или из сетевого ключа HASP, то производится попытка получения клиентской лицензии через сервер 1С:Предприятия.
    «N» — не получать клиентскую лицензию через сервер «1С:Предприятия».
    Значение по умолчанию — «N«.

    Zn — установка разделителей.

    ZN=<Общий реквизит 1>,<Общий реквизит 2>. <Общий реквизит N>

    <Общий реквизит> = [<+>|<->]<значение общего реквизита>

    [<+>|<->] — признак использования: «+» (по умолчанию) — реквизит используется; «» — не используется;

    Если разделитель не используется, то перед значением должен быть «-«. Если первым символом в значении разделителя содержится символ «+» или ««, то при указании его нужно удваивать.

    <значение общего реквизита> — значение общего реквизита. Если в значении разделителя присутствует запятая, то при указании ее нужно удваивать. Если значение разделителя пропущено, но разделитель должен использоваться, то используется символ «+».

    Разделители разделяются запятой.

    Например:

    «Zn=-ПервыйРазделитель,+,—ТретийРазделитель», что означает:

    Первый разделитель выключен, значение – «ПервыйРазделитель»,

    Второй разделитель включен, значение – пустая строка,

    Третий разделитель выключен, значение – «-ТретийРазделитель».

    prmod — запуск в режиме привилегированного сеанса. Разрешен аутентифицированному пользователю, имеющему административные права. Журнал регистрации фиксирует установку или отказ в возможности установки режима привилегированного сеанса. prmod=1 — привилегированный сеанс устанавливается.

    Строка соединения указывается в форме «Запуск 1С:Предприятия» под списком информационных баз, может быть задана в параметре командной строки выбора режима CREATEINFOBASE, как параметр метода СоздатьНачальныйОбраз().

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *