Перейти к содержимому

Как обратиться к элементу формы 1с

  • автор:

Шаблон кода: Как в 1С обратиться к элементу формы

Для того чтобы обратиться к элементу формы из модуля объекта этой формы и передать значение в переменную:

Шаблон кода:

мМойДокумент = ЭтотОбъект.Ссылка.ПолучитьФорму(«ФормаДокумента»); // получаем форму документа
НашаПеременная = мМойДокумент.ЭлементыФормы.Дата.Значение; // передаем значение переменной

Для того чтобы обратиться к элементу формы из модуля формы документа:

Шаблон кода:

УПРАВЛЯЕМЫЕ ФОРМЫ

Для того чтобы обратиться к элементу формы из модуля формы документа:

Для того чтобы программно установить значение поля в табличной части документа в :

&НаКлиенте
Процедура ТабличнаяЧасть1ТекущаяДатаПриИзменении(Элемент)
ТекСтрока = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
ТекСтрока.ОстатокОплаченыхДней = 111;
КонецПроцедуры

В данном случае при изменении поля ТекущаяДата происходит автозаполнение поля ОстатокОплаченыхДней.

Еще один пример — заполнение полей табличной части формы при начале редактирования:

Процедура ТабличнаяЧасть1ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
ТекущаяДата = Формат (ТекущаяДата (), «ДФ=dd.MM.yyyy» );
Если НоваяСтрока И Не Копирование Тогда
Элемент.ТекущиеДанные.ТекущаяДата = ТекущаяДата;
Элемент.ТекущиеДанные.Комментарий = «наш комментарий»;
КонецЕсли;
КонецПроцедуры

Для того чтобы записать какие-то данные в поле управляемой формы нужно создать прямо на форме элемент (реквизит создавать не нужно), например, поле ввода и прописать для него, например, результат функции в модуле формы:

Процедура ПриОткрытии(Отказ)
Реквизит1 = ПодсчетИтогаКассы();
КонецПроцедуры

Как обратиться програмно к элементу формы документа 8,3

(1) Действительно, он для отображения только.
"РегистрацияВНалоговомОргане" она только на форме.

При изменении его заполняются другие реквизиты табличной части

&НаКлиенте
Процедура НачисленныйНДФЛРегистрацияВНалоговомОрганеПриИзменении(Элемент)

ТекущиеДанные = Элементы.НачисленныйНДФЛ.ТекущиеДанные;
Если Не ЗначениеЗаполнено(ТекущиеДанные.РегистрацияВНалоговомОргане) Тогда
ТекущиеДанные.КодПоОКАТО = Неопределено;
ТекущиеДанные.КодПоОКТМО = Неопределено;
ТекущиеДанные.КПП = Неопределено;
ТекущиеДанные.КодНалоговогоОргана = Неопределено;
Возврат;
КонецЕсли;

ЗаполнитьЗначенияСвойств(ТекущиеДанные, СведенияОРегистрацииВНалоговомОргане(ТекущиеДанные.РегистрацияВНалоговомОргане), "КодПоОКАТО,КодПоОКТМО,КПП,КодНалоговогоОргана");

(9) Вот так :
ТекущиеДанные = Элементы.НачисленныйНДФЛ.ТекущиеДанные;
.
ТекущиеДанные.РегистрацияВНалоговомОргане

должно быть видно, что доп.колонка находится в коллекции всех реквизитов. Ничем от них не отличаясь. Конечно она в коллекции реквизитов формы есть, а в коллекции реквизитов объекта ее нет. Поэтому — смотри (2).

Обращение к элементам формы

Можно ли обойти по элементам таблицу формы
возможен ли обход таблицы упр. формы в цикле ?

Не удается обращение к элементам и методам формы из другой формы
Добрый день, Создал 2 формы, на второй есть паблик метод, элемент и несколько переменных, доступа.

Обращение из родительской формы к элементам второй формы
Помогите пожалуйста, надо динамически вывести dataGridView с таблицами данных из БД на дочернюю.

Обращение из первой формы к элементам второй формы
Имеются две формы задача при нажатии на одну кнопку скрывать некоторые данные со второй формы, а.

Лучший ответСообщение было отмечено Anastasia_Sokel как решение

Решение

То пишет ту же ошибку: Переменная ЭлементыФормы не определена

Добавлено через 39 минут
Еще одна проблема: При изменении флажка пытаюсь отчистить поле ГосНомерКузова, но выдает ошибку что поле недоступно, хотя очистить его пытаюсь, когда оно еще доступно.
Обращалась к полю редактирования еще так Элементы.ГосНомерКузова.ТекстРедактирования=""; но ничего не вышло

обращение к элементам формы
Добрый день! у меня есть форма form1 , которая содержит в себе несколько div c классом wrap. В.

Обращение к элементам формы
Всем привет..такой вот вопрос. Можно ли обратиться к элементу формы по индексу? И можно ли.

Обращение к элементам формы
Хочу из cpp сменить свойство (Text) элемента textBox1. При Form1->textBox1->Text = "Test"; выдает.

Обращение из класса к элементам формы
Добрый вечер, подскажите пожалуйста, как из класса обратиться к элементам формы(image, label и .

Обращение к элементам формы из JavaScript
Добрый вечер. У меня такая проблема. Занимаюсь с формами. Страница наполнена различными.

Обращение к элементам формы из класса
Как из класса test.cs присвоить значение textbox1 из формы Form1?

1с доступ к элементу

Надо кое-что подправить на одной форме. В справочниках есть управление складами. При редактировании или создании склада открывается форма: ФормаЭлемента. Там я создал кнопку и текстовое поле. На кнопку сделал обработчик нажатия. После нажатия в текстовом поле должно написаться сообщение.

Полный путь к форме:
Справочники-Склады-Формы-ФормаЭлемента.

Забыл вопрос задать. ) Как добраться до этого текстового поля, чтобы задать ему какой-то текст? Текстовое поле пусть будет называться: МоёТекстовоеПоле.

Nicolas Chabanovsky's user avatar

В обработчике события можно написать:

если МоёТекстовоеПоле — это элемент управления, а если реквизит формы, связанный с элементом управления, тогда:

Считаю, это некорректно. Как минимум по причине: попытался выполнить предложенный код, в результате получил ошибку:

<Форма.Форма(4)>: Поле объекта не обнаружено (значение) ЭлементыФормы.ПолеТекстовогоДокумента.значение = «11111»;

Обстоятельства. Создал внешнюю обработку. На форме внешней обработки разместил поле текстового документа. Код по кнопке выполнить:

Для того, чтоб в текстовое поле (поле текстового документа) вывести текст необходимо использовать метод этого текстового поля «УстановитьТекст(Текст)». Например:

Если же автор вопроса под текстовым полем имел ввиду просто поле ввода, тип значения переменной которого равен «Строка» тогда:

1) Не рекомендую обращаться к значению поля ввода через элементы формы, т.е. так:

2) При создании поля ввода автоматичсески создается реквизит формы, который содержит его значение. Вот как раз текст, который надо присвоить, и надо присваивать этой переменной:

Обстоятельства. Есть поле ввода: Имя поля ввода:»ПВМоёТекстовоеПоле», Имя реквизита формы(Данные):»РеквизитПВМоёТекстовоеПоле». Тип реквизита РеквизитПВМоёТекстовоеПоле — Строка. При этих обстоятельствах код для присвоения этому полю ввода текста будет такой:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *